EDV-Problem-Sammelthread: Schwarm-Intelligenz bitte kommen!

Metalfist

Metalfist

schnell und böse
Hallo!

Nachdem die SuFu nichts ausgespuckt hat, erstelle ich den Thread hier eben neu:
Meine Hoffnung ist schnelle Hilfe durch bassende EDV-Cracks.

Leider steht man als EDV-Anwender manchmal bei Problemen an und in einschlägigen EDV-Foren sind die Antworten so komplex, dass man schon wissenstechnisch soweit sein muss, das man mi dem Lösungsvorschlag erst recht nichts anfangen kann.
Deswegen hoffe ich auf simple Antworten durch Schwarm-Intelligenz.

Jetzt muss ich mich erst mal outen:
Ich kenn mich einen Dreck mit Access aus. Ebenso VBA und SQL.
Ich bin Techniker, aber bin rein auf EDV-Anwenderseite unterwegs.

Hier mein Problem:
Ich soll in meinem Job (ebenso alle EDV-mässig nur anwenderseitig unterwegs, darum kann ich auch niemanden fragen) eine simple Access2016-Formular für eine pdf-Bibliothek machen.
Eine Excel-Tabelle ist mit folgenden Spalten befüllt: Kategorie-Zuordnung | Titel | Hyperlink

Ziel ist ein einfaches Formular, in dem ich Datensätze über Kategorie (Auswahl mit Combobox) und Titel (Textfeld) suche.
Dieses Youtube-Tutorial bietet mir eigentlich genau das, was ich brauche und habe ich mich akribisch an die Erstellung gehalten.

Ich habe eine Abfrage erstellt, die so funktioniert wie ich mir das vorstelle.

Das Problem taucht beim Formular auf:
Hier hab ich eben eine Checkbox, ein Textfeld und einen Schalter (zum Resetieren der Checkbox+Textfeld) erstellt.
In Ereignisse habe ich bei Checkbox und Textfeld jeweils "nach Aktualisierungen" im Code "Me.Requery" eingetragen.

In der Abfrage habe ich auf diese Formularfelder verwiesen (Wie "*"&Formular!blabla!Textfeld&"*")
Wenn ich im Formular etwas eintrage oder eine Kategorie auswähle, dann werden die Werte brav an die Abfrage weitergegeben. Das funktioniert auch gut.

Das Problem ist, dass im Detailbereich des Formulars nicht automatisch die Datensätze aktualisiert werden.
Erst wenn ich auf den "Alles aktualisieren"-Button im Accessmenü klicke, werden die gewünschten Datensätze gezeigt.
So falsch scheine ich grundsätzlich nicht zu liegen.

Allerdings möchte ich unbedingt, dass die Aktualisierung automatisch funktioniert.
Eigentlich sollte das doch durch "Requery" im Code getan werden, oder?

Nächstes Problem ist, dass der Filterlösch-Button nicht funktioniert. Auch nicht wenn ich "alles aktualisieren" klicke.

Könnte es sein, dass das Access meine VBA-Anweisungen ignoriert? Kann es sein, dass VBA wegen Unternehmenssicherheits-Restriktionen (Stichwort: Trustcenter und ActiveX) nicht funktioniert? Oder gibt es allgemeine Einstellungen, die ich übersehen habe?
Ich weiss momentan echt nicht wo ich weitersuchen soll.

Über Inputs wäre ich extrem dankbar!
 
 

Oben Unten